DataStax Enterprise 3.0 Documentation

Installing glibc on Oracle Linux 6.x and later

This documentation corresponds to an earlier product version. Make sure this document corresponds to your version.

Latest DSE documentation | Earlier DSE documentation

Oracle Enterprise Linux 6.x and later do not, by default install the 32-bit versions of the glibc libraries. You need to install the libraries in order to install DataStax Enterprise.

To install glibc on Oracle Linux:

  1. Make the yum.repos.d your current directory.

    cd /etc/yum.repos.d
    
  2. Download the public-yum-ol6.repo package from the repository.

    wget http://public-yum.oracle.com/public-yum-ol6.repo
    
  3. Check that glibc.i686 is ready for installation and install it.

    yum list
    yum install glibc.i686