DataStax Enterprise 3.0 Documentation

Upgrading legacy versions

This documentation corresponds to an earlier product version. Make sure this document corresponds to your version.

Latest DSE documentation | Earlier DSE documentation

The procedures listed in these sections are based on upgrading from DataStax Community 1.0.x to DataStax Enterprise 3.0.x:

Generally, these procedures work for upgrading from other releases of Cassandra or DataStax Community to DataStax Enterprise 3.0.x. Exceptions are:

  • Upgrading directly from versions 0.8.8 and 1.0.3-1.0.5 to 3.0.x does not work. These older versions generate cross-dc forwarding and are incompatible with Cassandra 1.1, a component of DataStax Enterprise 3.0.x. First upgrade to 0.8.11 or 1.0.11, then upgrade to 3.0.x, and upgrade SSTables.
  • To upgrade from a Brisk release, contact Support.
  • To upgrade from Cassandra 0.8 or earlier, refer to NEWS.txt.